
Dia



Dia
Copyright © 2000 Kevin BreitHenry HouseJudith Samson

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License,
Version 1.1 or any later version published by the Free Software Foundation with no Invariant Sections, no Front-Cover Texts, and
no Back-Cover Texts. You may obtain a copy of the GNU Free Documentation License from the Free Software Foundation by
visiting their Web site [http://www.fsf.org] or by writing to: Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
MA 02111-1307, USA.

Many of the names used by companies to distinguish their products and services are claimed as trademarks. Where those names
appear in any GNOME documentation, and those trademarks are made aware to the members of the GNOME Documentation
Project, the names have been printed in caps or initial caps.

http://www.fsf.org




Table of Contents
1. Introduction ............................................................................................................ 1

Introduction ....................................................................................................... 1
1. Quickstart .............................................................................................................. 2

What Can You Do? ............................................................................................. 2
Starting Dia ....................................................................................................... 2
Quickstart Introduction ........................................................................................ 2
Creating a Canvas ............................................................................................... 2
Making a Diagram .............................................................................................. 2
Saving and Printing Your Diagram ......................................................................... 2
Who Does Dia Appeal To? ................................................................................... 3

2. The Canvas ............................................................................................................. 4
Canvas Introduction ............................................................................................. 4
Gridlines ........................................................................................................... 4
Rulers ............................................................................................................... 4
Background Color ............................................................................................... 4
Zooming ........................................................................................................... 4

3. Objects .................................................................................................................. 5
Objects Introduction ............................................................................................ 5
Using Objects ..................................................................................................... 5

Adding Objects ........................................................................................... 5
Moving Objects .......................................................................................... 5
Resizing Objects ......................................................................................... 5
Deleting Objects ......................................................................................... 6
Line Properties ........................................................................................... 6
Line Styles ................................................................................................. 6
Line Thickness ........................................................................................... 6
Arrows ...................................................................................................... 6
Line Colors ................................................................................................ 6

Object Properties ................................................................................................ 6
Colors ............................................................................................................... 7

4. Basic Objects .......................................................................................................... 8
Basic Objects Introduction .................................................................................... 8

Text .......................................................................................................... 8
Box .......................................................................................................... 8
Ellipse ...................................................................................................... 8
Polygon ..................................................................................................... 8
Beziergon .................................................................................................. 8
Line .......................................................................................................... 8
Arc ........................................................................................................... 8
Zigzag Line ............................................................................................... 8
Poly Line ................................................................................................... 9
Bezier Line ................................................................................................ 9
Images ...................................................................................................... 9

5. Special Objects ...................................................................................................... 10
Special Objects Introduction ................................................................................ 10
Special Object Categories ................................................................................... 10

6. Selecting Objects ................................................................................................... 11
Selection Introduction ........................................................................................ 11
How To Select Objects ....................................................................................... 11

Basic Selection ......................................................................................... 11
Multiple Selection ..................................................................................... 11
Other Ways for Selecting Objects ................................................................. 12
Selecting Connected Objects ....................................................................... 12

iv



Selecting Transitive Objects ........................................................................ 13
Selecting Same Type of Objects ................................................................... 13

7. Loading and Saving Diagrams .................................................................................. 14
Loading and Saving Introduction .......................................................................... 14
File Types ........................................................................................................ 14

Native Dia Diagram Files ........................................................................... 14
Import Formats ......................................................................................... 14
Exporting: Support for Other Formats ........................................................... 14

8. Customization ....................................................................................................... 16
Customization .................................................................................................. 16

9. Managing Layers ................................................................................................... 17
Introduction to Layers ........................................................................................ 17
Managing Layers Basics ..................................................................................... 17

Create a New Layer ................................................................................... 17
Selecting Layers ....................................................................................... 17
Ordering Layers ........................................................................................ 18
Deleting Layers ........................................................................................ 18

Viewing Layers ................................................................................................ 18
10. Authors .............................................................................................................. 20
11. License .............................................................................................................. 21

License ........................................................................................................... 21

Dia

v



List of Figures
1.1. Demo .................................................................................................................. 2
3.1. Adjuster Dots ....................................................................................................... 5
3.2. The line icon ........................................................................................................ 6
3.3. Line properties ...................................................................................................... 6

vi



Chapter 1. Introduction
Introduction

Dia is an application for creating technical diagrams. Its interface and features are loosely patterned after
the Windows program Visio. Features of Dia include multiple-page printing, export to many formats
(EPS, SVG, CGM and PNG), and the ability to use custom shapes created by the user as simple XML
descriptions. Dia is useful for drawing UML diagrams, network maps, and flowcharts.

This document describes version 0.94 of Dia.
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Chapter 1. Quickstart
What Can You Do?

Dia is a diagraming application made for many people. Dia is easy enough to learn without much hassle
and flexible enough to make the power users feel right at home with their commercial tools. Below is an
example of what five minutes of using Dia can provide.

Figure 1.1. Demo

Starting Dia
You can start Dia by going into the Applications section on the Main Menu and clicking on the Dia icon.
Or, you can type dia in a xterm window.

Quickstart Introduction
The Dia Quickstart for the user who doesn't want to read a whole manual to make a basic diagram.

Creating a Canvas
All diagrams are drawn in their own canvas. To create a new canvas, select File->New Diagram A new
canvas window will appear.

Making a Diagram
A diagram is made up of objects. Objects are shapes that can be different colors, shapes, and sizes. They
include everything from 2-bit images to full color pictures to text.

To add object to the canvas, click on an object in the toolbox and click on the canvas. The selected ob-
ject will appear. The object can be manipulated mainly by clicking and dragging on the green corner
buttons.

In the toolbox, you can double-click on any object to view its advanced properties. This allows you to
customize the stock shape more to your liking.

Layers create multiple-images so they are one image. By doing this, a user can edit one layer without
worrying about affecting any of the other layers.

Transparency allows objects to have transparent parts of an object, so anything behind the transparent
section shows through.

Plug-ins allow the average user to easily add new object types to Dia, to help extend its functionability.

Saving and Printing Your Diagram
Saving your diagram and printing your diagram is as easy as creating and modifying your document.
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Dia supports saving and printing to printers. If you have gnome-print installed, the printing is very easy!

The print command can be found in the File menu when right-clicking on the canvas.

Dia supports exporting to numerous formats for excellent web publishing. Some of them include:

• Computer Graphics Metafile (.cgm)

• Encapsulated Postscript (.eps)

• Native Dia Format (.dia)

• Portable Network Graphics (.png)

• Scalable Vector Graphics (.svg)

Who Does Dia Appeal To?
Dia can appeal to many people in a variety of industries.

• An electrical engineer may use Dia to create a diagram to show how their circuit works.

• A computer programmer may use a flow chart to show the execution path of their program.

• A network administrator is able to create a diagram to show how their company network is layed
out.

Quickstart
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Chapter 2. The Canvas
Canvas Introduction

The canvas is the main part of Dia. The Dia canvas is the window where all the user's objects will be
placed on the screen and arranged. When the diagram is printed or saved, the contents of the canvas will
be saved.

Gridlines
Gridlines are similar to the lines on graph paper. They allow the user to easily align objects on the can-
vas. The gridlines can be hidden by going into File -> Preferences . In the Grid Lines tab, the user
should click on the Visible button so it says No.

Rulers
Rulers appear on the top and the left of the Dia canvas. They show, in centimeters, how large your can-
vas is.

On each ruler exists an arrow. The arrow moves on the ruler in coordination with where the mouse
pointer is. For example, if the user moves the mouse up, the vertical ruler's arrow will move up, indicat-
ing the change. These arrows become useful when an object needs to line up exactly at a certain meas-
urement point.

Rulers, unlike gridlines, cannot be removed.

Background Color
The background color option allows you to change what the background looks like in the canvas. By de-
fault, the color is white. However, the color can be changed by going into View + Diagram Properties ->
Background and clicking on the bar. The bar displays what your background color is. The gridlines will
change their color automatically to stay visible if the background color is changed to black.

Zooming
Zooming allows the user to get up closer to their diagram. This helps to let the user make precision
drawings.

The canvas can be zoomed up to 400%. Zoom can be done by clicking on the magnifying glass on the
toolbox and clicking on the canvas. To zoom out, hold the shift button and click again on the canvas.
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Chapter 3. Objects
Objects Introduction

Objects are what makes up a diagram. Objects are shapes which are either pre-defined or user-defined.

Using Objects
Adding Objects

Adding objects to the Dia canvas can be accomplished by clicking on the desired object in the toolbox to
select what you want placed on the canvas. Clicking on the canvas will then place the object on the can-
vas.

Dia provides two types of objects:

• User-defined objects allow a user to create their own objects, which are based off of a prefabricated
template.

For example, clicking on the square object and placing it on the canvas, creates a square. However,
the dimensions of the object can be changed. See the Resizing Objects section for more information.

• Pre-defined objects are mostly designs which cannot be edited. They can be resized, but the object it-
self cannot be edited.

Moving Objects
When an object is inserted into the canvas, the desired object will appear with small green boxes defin-
ing the borders.

Figure 3.1. Adjuster Dots

The area inside the boxes is the object area. Click and hold on the object area. Then move the mouse
around, inside the canvas, to move the object to another place on the canvas.

Resizing Objects
The previous paragraph, explains the concept of the green boxes. These are used to manipulate the size
of the object. To change the size, click and hold on a green button. Drag to the respective size, then let
go.

The corner green buttons will change both height and width at the same time. The two on the top and
bottom edges, in the center will edit height while the two on the left and right edges, in the center will
edit width.

Tip

To drag with the corner buttons, but keep proportions, hold the shift key while resizing. This
only applies to the special objects, not regular shapes.
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Deleting Objects
To delete an object, click on the object to select it. The green boxes will appear. Hit Ctrl+D and the ob-
ject will disappear.

Line Properties
One of Dia's objects is the line. The line object is symbolized by the following icon:

Figure 3.2. The line icon

Line Styles
Lines can be easily edited to easily create items such as arrows. At the bottom of the toolbox is 3 buttons
with lines through them. Clicking and holding will open up a menu which demonstrates what the change
will look like.

Figure 3.3. Line properties

Lines can employ different style types such as:

• Solid

• Dashed

• Dash-Dot

• Dash-Dot-Dot

• Dotted

Line Thickness
The thickness of lines can be edited by clicking on the five thicknesses to the right of the color selector.

Arrows
The line tool can be used to create arrows. By clicking on the two side buttons on the bottom of the tool-
box, a menu pulls out showing the possible beginning and end designs for the arrows.

Line Colors
The line color can be edited by double-clicking on the line once it has been placed on the canvas. A win-
dow will show up. The second line is labeled as "Line Colour" with a bar demonstrating the selected
color. By clicking on the bar, you can change the color of the line.

Object Properties

Objects
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Each object has its own properties assigned to it. They can be accessed by double-clicking on an object
already on the canvas. A window will appear allowing you to edit numerous properties including:

• Line width

• Line color

among others.

Colors
All the objects can be colored in different ways, according to a user defined setting.

The color control is located near the bottom of the toolbox. There are two squares make up the control.
The one on the top left is the foreground color. The one in the bottom right is the background color. To
edit the colors, click on the desired box and select the color in the color window that appears.

Note

This control will only allow the selection of colors of objects which have not yet been placed
on the canvas.

Tip

To inverse the colors, click on the little arrow to the top right of the two boxes.

Tip

To set the colors back to the default, click on the black and white box to the bottom left of the
color selector.

Objects

7



Chapter 4. Basic Objects
Basic Objects Introduction

The first, and most common type of object is the basic object. Basic objects normally are geometric
shapes, which can be customized. Dia offers the user numerous basic objects.

Text
Dia supports the use of text as its own type of object. Text can be placed on the canvas by clicking on
the text button on the toolbox.

Note

Text in Dia can use any font available to Gnome.

Box
The boxes in Dia can be customized to be any size desired by the user. The properties available are:

• Corner Rounding - Causes the corners to be rounded instead of hard edges.

• Draw Background - Keeps the center clear or fills with the background color.

Ellipse
An ellipse is a shape which has all rounded sides, such as a circle or an oval.

Polygon
A polygon is any closed shape made up of straight lines. The polygon tool, allows the user to draw any
shape with all straight lines.

Beziergon
A beziergon is similar to the polygon as the user defines the shape. However, it differs in that it allows
curves to exist in the shape.

Line
A line simply...a line. Refer to the customizing a line section to find more information about a line.

Arc
An arc is a line which has been bent to create a semi-circle shape.

Zigzag Line
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A zigzag line is a line which has sharp, 90 degree turns in it. They hold visual similarities to staircases.

Poly Line
A poly-line is like a zigzagline, but does not necessarily have to have 90 degree turns to it. The angles
can be customized.

Bezier Line
A bezier line is a line which has curves in it. The bezier line tool is edited by clicking and dragging the
green and orange dots. The green dots customize the size while the orange dots customize the angles at
which the line curves at.

Images
The Dia canvas can have pictures inside of it, as well as shapes.

To add an image, click on the image button and then add it to the canvas. An object that says "Broken
Image" will appear. Double-click to open the properties. Click on "Browse" and select your file. Click
"OK" and then the image will be updated accordingly.

Basic Objects
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Chapter 5. Special Objects
Special Objects Introduction

The previous discussion explained what a basic object is. The next section goes a step further and
teaches how to create objects, how to use pre-made objects which are more detailed than just shapes,
and much more!

Special Object Categories
Special objects are broken into different categories. This way, someone creating a diagram of a circuit
board can see only the objects which apply to them. Dia supports numerous pre-defined categories.

Circuit A group for people interested in creating diagrams of electrical circuits.

Ladder This one is beyond my knowledge

ER Editor for Entity Relations Diagrams

FS Editor for Function Structure Diagrams

Flowchart A group dedicated to providing the user shapes which are commonly used
in flow charts. Flow charts can be routinely found in computer program-
ming, marketing, economics, and any other semi-linear operation which re-
quires planning.

GRAFCET A chart which diagrams the step, the action, the transition, and the condi-
tion associated to the transition.

SADT Good question!

UML Refer above

Chronogram Uses objects to be used in a chronographic design. These are common
place in time lines.

Network Used by network administrators to create a design of their network.

Sybase Designs diagrams display the flow of a Sybase computer network.

Electric Shows flow of electricity, I guess

Pnumatic/Hydraulic Allows diagraming of a device which employes hydraulics.
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Chapter 6. Selecting Objects
Selection Introduction

Selecting objects is probably the most frequently task when using Dia. From the moment you create a
new object to the moment you think the diagram looks the way it should be, you will always have to se-
lect objects to set them up properly.

When you select objects, you bring focus to an object to edit. An object which is not selected, cannot be
edited.

Selecting objects can be done in many different ways, and there are also many operations can be per-
formed on these selected objects.

You can select objects to simply drag them around the diagram, or to group them in a logical way to ma-
nipulate them more easily, to connect them each others, or to simply remove them from the diagram.

How To Select Objects
Basic Selection

The basic way to select an object is by clicking on it.

When the object is selected it appears on the diagram with some little green points on its corners and on
its sides.

Once the green points appeared, you can start manipulate this object as you wish. When you're done
with it you can deselect this object by clicking on any free space of the diagram, the green points will
desappear and selection of an other object becomes possible.

Multiple Selection
The simplest way to select more than one object at the time, is by clicking on a free space of the diagram
with the left mouse button and moving the mouse while pressing on it. Doing so will draw a thin rect-
angle on the Canvas. All objects present in this area will be selected when depressing the button.

An other way to do so is by holding down the Shift key while selecting the objects by clicking them one
by one.

Once your selection is complete, each of the selected objects must appear with its own green points as
described above.

Multiple selection is useful when you want apply the same operation on many different objects and you
don't want waste time by selecting them one by one.

When selected, objects act like a group. Meaning if you try to drag one of them, it is the whole group
which moves. The same if you try to delete one of them, it is the whole group will be removed from the
diagram.

Then if you click on any free space on the diagram or if you change to another layer, you will loose the
selection. Or if you want to add some more objects to your selection, simply hold down the Shift key
again and click on the items you want add.
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Note

Assuming you selected some objects on your diagram, it is still possible to resize one of them
without changing the size or position of other selected objects. To learn how to resize objects
see the Resizing Objects section.

Other Ways for Selecting Objects
Other ways for selecting objects are describe below, all these options can be reached in the Main Popup
Menu under the Select menu :

Selecting all objects Choosing the All option will let you select all the objects present
on the current layer, the same way as you could do it by hand.

This option is a shortcut of when your diagram contains a lot of
objects and you don't want waste your time in selecting objects
one by one.

Deselecting all objects Selecting the None option will deselect objects you have selected
before. It has the same effect as when you clicking on any free
part of your diagram.

After you have deselected objects you cannot perform any opera-
tion on them anymore. So you have to select them again to contin-
ue

Tip

Often you will have to keep your selections persistent, to do so, you can form an arbitrary
group with the selected items or cut and paste them in a new layer which will contain all the
objects of your selection.

Inverting the selection Admiting you have ten items on your diagram and want to select
only eight of them. One way to select these eight objects can be
done by the Invert option under the Select menu.

Simply select by hand the two objects you don't need, then check
the Invert option and you will get the eight objects you wanted
being selected and the two others left on their owns.

Tip

Another way to do this is to select All the items as described above, and then press the Shift
key and deselect the objects you don't need.

Note

Only objects present in the current layer can be selected. If an object doesn't want to be select
it's probably because it is situated in another layer. To know how to change the current layer or
how to manipulate many layers, please refer to the Managing Layers section.

Selecting Connected Objects
One really useful and powerful feature of Dia is its ability of handling connection between objects.

Selecting Objects
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Connections, in Dia, can be used for many purposes. The first, and not the least, is to explicitly specify a
direct relationship between two objects.

The second could be it is easier to manage objects that behave efficiently in following established rules
and can be accessed in a few clicks.

Selecting objects connected to a particular object, is as simple than selecting this particular object, right
click on the Canvas to get the Main Popup Menu appear and click on the Select->Connected button.

If this object doesn't have any object connected to it, it will do nothing. Otherwise, all the connected ob-
jects will be magicaly selected and will form a new group of temporary selected objects.

Note

If you repeat this manipulation again, that will be all the connected objects to this new group
that will be add to the selection.

You can redo the operation until you have selected all objects that were connected all together.

Selecting Transitive Objects
Technic shown above is fine when you only want select a small number of connected objects at the time.

Sometimes you will have to select a whole bunch of objects which are connected all together. This way
of selecting objects step by step isn't efficient.

This is the reason why Dia offers you to do all these steps at once.

To do so, select the root object you desire, then right click on the Canvas to have the Main Popup Menu
appear on screen, but this time choose the Select->Transitive button instead of Connected.

And that's it, all objects that were connected to the root object you choose are now selected and ready to
be manipulate and waiting for you to apply on them any number of operations you would like.

Selecting Same Type of Objects
Dia implements some trick to select objects issued from the same type.

Meaning if, for any reason, you need to select objects matching the same type (all Rectangles, Lines or
any custom Shape) you could do it by selecting an object of the type you need to select and click, in the
Main Popup Menu, the Select->Same Type button.

This will automaticaly select all objects which correspond to the type you have chosen. Only objects
present in the current layer will be selected.

Selecting Objects
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Chapter 7. Loading and Saving
Diagrams
Loading and Saving Introduction

Dia follows the saving model common to most desktop applications: you must explicitly save any
canvases that you wish to retain for future use. To save a file, choose File->Save from the Main Popup
Menu. The result is a standard save dialog. Your canvas is saved in Dia XML format. No file extension
is automatically added, so it is a good idea to explicitly add '.dia' to the name you enter.

To load a canvas from a file previously saved by Dia or created by another application, select File-
>Open... from the Main Menu Bar. The result is an open dialog; select the file you want and choose
Open. The open dialog is standard apart from the popup menu labeled Determine file type. Choose the
format of the file to open (Dia XML or Drawing Interchange) if Dia does not correctly determine the file
format unassisted.

An alternate file-loading method is to start Dia from the command line with the name of the file to open
given as an argument.

File Types
A few words on file types are in order. You should be aware that not all format of files can be re-loaded
into Dia after saving and that most supported file formats lose information to some degree.

Native Dia Diagram Files
The only format guaranteed to be lossless is Dia XML. Happily, you are unlikely to accidentally save in
a lossy format because File->Save always produces a file in Dia XML format.

Files in Dia XML format are automatically compressed using gzip to save disk space. This is almost ne-
cessary since, without compression, even simple diagrams are very large because they store much re-
dundant information. Because Dia XML files are already compressed, you should not try to compress
them manually—it will not help.

Import Formats
Dia is able to import the following file types:

• SVG

• DXF

• XFig

Exporting: Support for Other Formats
Dia supports exporting to many other types of file, such as:

• Computer Graphics Metafile
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• Dia shape file

• DXF

• HPGL

• EPS

• PNG

• SVG

• TeX Metapost macros

• TeX PSTricks macros

• WPG

• XFig

• XSLT

Dia cannot load files in most of these formats. These formats are useful for diagrams that you need to
use in another application or to distribute to users of another operating system that Dia does not support.

To create a file in one of these formats, select File->Export... from the Main Popup Menu. Choose a
name and the desired format in the resulting dialog, which works like a save dialog. An appropriate file
extension is automatically added.

Loading and Saving Diagrams

15



Chapter 8. Customization
Customization

Dia can be changed in a few ways, allowing the user to make Dia fit more to their needs.

To change the behavior settings, select File->Preferences... from the Main Menu Bar. This opens the
Preferences dialog, shown in

The configurable properties in the User Interface tab are:

• Reset tools after create — If this button is checked…

• Number of undo levels customizes how many steps that the undo tool remembers. Higher numbers
let the user go back more steps to fix an error, but take up more memory.

• Width controls the width, in pixels, of a new diagram.

• Height controls the height, in pixels, of a new diagram.

• Magnify sets a multiplier that controls what the default zoom level on a new diagram is.

• Snap To allows makes objects attract to a grid created by the program. This makes it easier for the
user to align objects, as separate objects snap to the same line.

• X Size lets the user set a multiplier which sets how far the horizontal grid lines are from eachother.

• Y Size lets the user set a multiplier which sets how far the vertical grid lines are from eachother.

• Colour sets the color that the grid lines display as.

After you have made all the changes you want, click on OK to apply the changes and close the Prefer-
ences dialog. To cancel the changes and return to previous values, click the Close button. You may pre-
view the effect of your changes using the Apply button.
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Chapter 9. Managing Layers
Introduction to Layers

In Dia, layers are managed through the Layers Dialog and all layers related operations can be achieved
from this dialog.

As a general purpose, layers aim at being a shortcut for grouping related objects within a diagram. They
allow you to isolate the different parts of a diagram, in the way which you can decide to show only cer-
tain parts of it and not some others will stay hidden even when exporting or printing the diagram.

Inside a layer, any operation you would like to perform on objects are possible through the Main Popup
Menu, then you can act on objects just the way you use to.

Note

Only objects present in the current layer can be selected. If an object doesn't want to be selec-
ted, you should check if it is laying in the current layer or not.

By default, each new diagram comes with the default layer which it's called the Background layer. Of
course you can change its name and settings to customize it to your needs as you can do with any other
layer.

You can create as many layers as you want, Dia will put a new layer on top of all the layers have been
already created. Layers can be thought as a stack of transparent papers. Meaning you will be able to
change their stack order, decide whether or not to show them, draw any number of objects onto them
and so on.

All this can be manage through the Layers Dialog.

Managing Layers Basics
Create a New Layer

Creating a new layer is possible by clicking on the New Layer button at the bottom left of the dialog.
Since the Layers Dialog is not diagram specific but application specific, you will have to choose in wich
diagram the new layer must go in. To do so, at the top of the Layers Dialog, select the diagram you
wanted to receive the new layer and then add this new layer to the selected diagram.

The newly created layer will be placed on top of the stack and will become the current layer of the selec-
ted diagram.

Then it's possible to edit any new object of your choice, copy and paste from any other layer or diagram
as you could do it in single layer diagram.

Selecting Layers
A layer is said as being activated when it is selected in the Layers Dialog. To select a layer simply click
on its name in the dialog, that will highlight it. From now, any changes you will make to the diagram
will affect this layer and only this one.

Note
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You'll be able to select only one layer at the time. That way you can do anything you like in
this selected layer without affecting other layers on your diagram.

Ordering Layers
Next to the New Layer button at the bottom of the Layers Dialog, are two useful buttons which allow
you to set the stack order of each layer you created.

Those two buttons are used to raise and lower layers in the hierarchy of layers. The button with the up
arrow is used to raise the active layer while the other is for lower the position within the hierarchy.

Ordering layers can be useful when you want hide some parts of an object with another one.

Deleting Layers
When a layer is not needed anymore you can delete it and all the objects it contains by clicking on the
Delete Layer button. Of course this will only affect the currently selected layer.

Doing so on regular basis is the better way to keep your diagram clean and light for when you want to
export it to another format than the native Dia format.

Note you should be aware of any diagram you created must at least contains one layer, only because a
diagram is built of layer, so a diagram doesn't contain any layer should be considered as a corrupted dia-
gram and won't be suitable to export nor even save in the native Dia format.

Viewing Layers
Now that you've seen what are the basics of manipulating layers, you will more easely understand why
layers are such a powerful tool when you are building a diagram with Dia.

Understanding what layers are for can dramaticaly improve the quality and the visual effect your dia-
grams will produce.

For instance, imagine you are building a diagram with lots of objects in it, like an Electrical or UML
diagram, if you drop all of your objects in the same layer, meaning the background, after a while you
will get a huge unmanageable draft you won't be able to do anything with it. It will be a pain to change
anything in it, you will waste time trying to remenber what object is connected to that object which
seems to take all the place in the middle of the mixed up objects you already put there.

Since Dia is a Structured Diagram Builder, all the diagrams you will build with it will be naturaly struc-
tured and broken down in many little pieces you will manage with more ease and efficiency than you
could do it with a single monolythic block of objects.

Note

By definition, a diagram should be structured, so breaking it down in several logical parts won't
be as hard as it seems to be. That's where layers becomes of first use. They allow you to isolate
each of these parts in separated slides, so it becomes a real pleasure to manipulate them in any
way you like.

First, layers can be renamed to express the part of the diagram they represent, giving them the ability to
be rapidely located among others. And most importantly, layers can be shown or hidden depending on
what part of the diagram you would like to show.

To rename a layer, at any moment during the construction of the diagram, double-click on the name of
the layer in the Layers Dialog. This will bring up the Layer Attributs pop up dialog where you'll be able

Managing Layers
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to change the name of the layer.

Tip

Try to find some name which matches the purpose of the layer is a useful way to remember
what it is for. Don't hesitate to create many different layers in your diagram, Dia doesn't con-
strain you on the number of layers you've created, so feel free to adjust your own hierarchy to
your needs.

The Eye Icon on the left of the layer's name is what make layers so useful, it aims at hiding or showing
the corresponding layer. Meaning if for any reason you decided to not show a particular layer, simply
click on the Eye Icon and the layer and everything it contains will disappear from the Canvas.

Viewing only certain layers is really useful when you want manipulate a small part of your diagram
without affecting the rest. You can also work that way if you want to print your diagram on different
pages or testing different settings which can affect the layout of that part. Again, feel free to experiment
with layers, if set up properly they can make your diagram looks pretty much better.

Note

In Dia, Layers creation and manipulation are as common as drawing or selecting objects in the
diagram. You must get your hands on them, because you will probably have to use them any-
time you will want to creat a new diagram.
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Chapter 10. Authors
Dia was written by Alexander Larsson and is currently maintained by James Henstridge. To find more
information about Dia, please visit the official web page, www.gnome.org/projects/dia
[http://www.gnome.org/projects/dia]. Please send all comments, suggestions, and bug reports to the
GNOME bug tracking database [http://bugs.gnome.org]. (Instructions for submitting bug reports can be
found on-line [http://bugs.gnome.org/Reporting.html].) If you are using GNOME 1.1 or later, you can
also use Bug Report Tool (bug-buddy), available in the Utilities submenu of Main Menu, for submitting
bug reports.

This manual was written by Henry House (<hajhouse@houseag.com>) , Judith Samson
(<judith@samsonsource.com>), and Kevin Breit (<battery841@mypad.com>). Please send
all comments and suggestions regarding this manual to the GNOME Documentation Project
[http://www.gnome.org/gdp] by sending an email to <docs@gnome.org>. You can also add your
comments online by using the GNOME Documentation Status Table
[http://www.gnome.org/gdp/doctable/].
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Chapter 11. License
License

This program is free software; you can redistribute it and/or modify it under the terms of the GNU Gen-
eral Public License as published by the Free Software Foundation; either version 2 of the License, or (at
your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY;
without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE. See the GNU General Public License for more details.

A copy of the GNU General Public License is included as an appendix to the GNOME Users Guide.
You may also obtain a copy of the GNU General Public License from the Free Software Foundation by
visiting their Web site [http://www.fsf.org] or by writing to

Free Software Foundation, Inc.
59 Temple Place - Suite 330

Boston, MA 02111-1307
USA
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